FAQ

If you could not find an answer to your problem in our FAQ pages, please submit a Tech Support Form

 

We urge all IK users not to install macOS 10.15. Our team is currently working on full compatibility for our products.

For users who have updated already or inadvertently, your products should work okay as long as they were installed and authorized before the update.

For users who have a fresh installation of macOS 10.15 Catalina, or for those who have purchased new products after updating, use the FAQ here if you need help installing any compatible products.

Currently these programs are working with macOS Catalina and we have provided compatible updates to the following programs in your IK User Area:  T-RackS 5.2.2, AmpliTube 4.9.0, Hammond B-3X version 1.1.1, SampleTank 4 version 4.0.9, AXE I/O Control Panel 1.1b, Custom Shop 1.9, and Authorization Manager 1.0.27.

Please check this page or your IK product's specifications page for full information on the current officially compatible operating systems.

If you need any extra help or information after reading this FAQ, please contact our support team.

 
FAQ ID: 1264

x

We use cookies and other tracking technologies to improve your browsing experience on our site, show personalized content and targeted ads, analyze site traffic, and understand where our audience is coming from. To find out more or to opt-out, please read our Cookie Policy. To learn more, please read our Privacy Policy.

By choosing I Accept, you consent to our use of cookies and other tracking technologies.

 

I Accept

Please wait...

10% Complete (success)